Tag Archives: refresh rate

Benq e2200HD and the HDMI Port

Screen flickering like a strobe light isn’t a good thing, right?

I have a Benq e2200HD 22″ flat panel monitor. While I was using Windows 7 Ultimate RC, I noticed faint flickering while playing Far Cry 2. It wasn’t the usual type of flickering, where the screen goes black for a moment and then the desktop reppears again. It was so faint that I didn’t think anything of it. It’s been two weeks since I installed Windows 7 Home Premium. A couple of days ago the flickering came back and it got worse. It was no longer limited to Far Cry 2. My desktop was also flickering and it was giving me a headache.

My first instinct was to change the monitor’s refresh rate. My screen resolution was 1920×1080. When I attempted to change the resolution rate, from 59Hz to 60Hz, it did nothing. When I mean it did nothing I mean that the change did not save and I was stuck at 59Hz. I googled and plenty of people are having problems being unable to change their refresh rates in Windows 7. The current consensus is that unlike previous Windows, Windows 7 is rounding down the number instead of rounding up. I tried to use the nVidia Control Panel to create a new resolution. I was able to change the refresh rate to 61Hz but it did nothing. Meanwhile, the flickering got so bad, I changed the resolution to 1440×900. From there I was able to bump up the refresh rate to 75Hz. However, this was only a temporary solution.

I became worried that there was something wrong with the card. You see, I also have our 42″ Samsung hooked up to my computer so we can watch videos on our TV. The flickering was also happening there until I changed the resolution and refresh rate. The next step was to buy a new monitor cable. I didn’t have very high hopes that this would work. Here’s where the real purpose of this post comes into play.

I bought a DVI to HDMI 2m cable from Digimania for 19€. I plugged the HDMI end into the monitor and the DVI end into the EVGA card. I turned the monitor on and nothing happened! The only thing on the screen was the message “No cable connected”. I immediately thought, “This better not be a bad cable!” I reseated the connections and tried again. Still nothing happened. After a while of thinking, the screen turned off and on as if it was trying to find the right screen resolution or something. A messaged popped up for a split second saying “DVI”. Well, the problem there was that HDMI port is supposed to be in use. I plugged the EVGA-provided HDMI to DVI adapter onto the cable and plugged it into the monitor. It instantly found the connection and from there, using the monitor’s menu, I was able to change the “Input” setting under “System” to HDMI. After that, the monitor was able to detect that the HDMI port was in use.

So apparently, the Benq e2200HD’s HDMI port needs to be enabled first using the monitor’s menu before you can use it. I don’t understand why they did that. But, oh well the connection is working now and I do not have to re-enable it. As for the S-Video connection from the card to our TV, I’ll have to live with it for the time being until I can afford to buy a replacement cable for the one I am using now.